Automation Reply Loops When Processing Message Replies

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Problem

Automated reply handling can result in an unintended reply loop between recipients and Engage. This can cause repeated automated messages to be sent when replies continuously trigger the same automation or whiteboard.

Cause

Replies can be processed automatically through event-based automations or whiteboards. While Engage filters most auto-replies, some replies are not identified as such or are considered valid replies.

If the automated reply is sent from the same group as the original message, incoming replies can repeatedly trigger the same automation, creating a reply loop.

Resolution

To prevent reply loops, use segmentation to exclude contacts who have already received the automated reply within a defined timeframe.

1) Create the segmentation

You’ll need to create or update a segmentation to exclude repeat contacts with the following rules:

  • Contact Profile > Group Membership

    • Member of a specific group: Select the group that both the main sendout and the automation-triggered reply use.

  • Email Activity > Received

    • Received: No

    • Additional Criteria: Message

    • Message Type: Prepared

      • Select the prepared message that the reply event automation sends

    • In Timeframe: Relative Date Range > Before Run

      • From: Before, 1 day before the run date (Adapt this timeframe according to your needs)

      • To: On Run.

2) Update the Event Automation

  1. Go to the Engage > Automations > Event-Based.

  2. Look up the event automation that processes replies, and select the tick box for the chosen automation. Then click on Deactivate at the bottom of the page.

  3. Edit the automation by selecting the pencil icon.

  4. In Edit Define Event, scroll down to Define Segment. If you already have a Segment defined, you’ll need to cancel the changes to the automation and add the appropriate steps to that automation. Otherwise, select the segment created in section 1 above.

  5. To return to the event automation list, click on Edit Job at the bottom of the page, then Time Frame, and finally, Save and close on the last page.

  6. Lastly, tick the selection box for the automation and click on Activate.

Result

After a message is sent from the group, a recipient reply triggers the automation.

The segmentation prevents contacts who have already received the automated reply from triggering the automation again, avoiding reply loops.

Additional Information

This approach is recommended whenever:

  • Automated replies are sent from the same group as the original message

  • Event-based automations process incoming replies

  • Repeated or cyclical replies are observed

Document Technical Reference: h75nt